1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

I donated but my vip has gone away

Discussion in 'Donations' started by MR.Sir Noble, May 23, 2017.

Thread Status:
Not open for further replies.
  1. MR.Sir Noble

    MR.Sir Noble VIP Member

    Joined:
    Dec 28, 2014
    Messages:
    3
    Likes Received:
    0
    Steam:
    Steam SteamRep SourceBans gameMe
    Yo so long story short i donated a pretty long time ago to get vip. I donated the amount required to get ''permanent'' vip. i was very pleased with my new vip status. But after some time i stopped playing tf2 and now i have started playing a little bit again but my vip doesnt work anymore. Can anyone help me?
     
  2. Luigi123

    Luigi123 Member

    Joined:
    May 15, 2015
    Messages:
    517
    Likes Received:
    68
    Steam:
    Steam SteamRep SourceBans gameMe
  3. old bear

    old bear Member

    Joined:
    Nov 7, 2016
    Messages:
    18
    Likes Received:
    1
    Steam:
    Steam SteamRep SourceBans gameMe
    You can no longer have permanent VIP but only up to 1 year
     
  4. Archaon Everchosen

    Archaon Everchosen Chaos Marks Us All Senior Server Admin VIP

    Joined:
    May 28, 2015
    Messages:
    204
    Likes Received:
    20
    Steam:
    Steam SteamRep SourceBans gameMe
    Vip on Forum not enough?
     
  5. n0name

    n0name Founder VIP

    Joined:
    Aug 27, 2012
    Messages:
    7,070
    Likes Received:
    1,398
    Steam:
    Steam SteamRep SourceBans gameMe
    Seeing how your VIP on the forum still shows up, it seems like your account still has the VIP status (otherwise, it would get remove as well).
    Looking in the DB, your Steam account indeed has a valid TF2 lifetime VIP status.

    Please check in-game if you can access the !donator menu.
     
  6. MR.Sir Noble

    MR.Sir Noble VIP Member

    Joined:
    Dec 28, 2014
    Messages:
    3
    Likes Received:
    0
    Steam:
    Steam SteamRep SourceBans gameMe
    yea it seems it was just a matter of linking my account and having a bit of patience. it all works now thanks for the help!
     
Thread Status:
Not open for further replies.